USFCard Services Maintenance Continued

Incident Report for USF IT Systems Status Page

Resolved

This incident has been resolved.
Posted May 12, 2025 - 16:00 EDT

Identified

USFCard Services are partially unavailable right now due to the ongoing system update from this weekend taking longer than expected. Please disregard the notice from earlier saying the update was completed. Currently, our team is unable to print cards, but they are still able to review applications and assist with submitting requests.
Posted May 12, 2025 - 10:45 EDT
This incident affected: Other.