Issues With Microsoft Copilot

Incident Report for USF IT Systems Status Page

Resolved

Microsoft has implemented a fix and Copilot functionality should be fully restored at this time.
Posted Jun 04, 2025 - 17:13 EDT

Identified

There is currently a widespread issue with Microsoft Copilot functionality. Some users may see an error such as "Service communication is currently unavailable" when trying to use Copilot chat or within Microsoft 365 programs. Microsoft is aware of the issue and currently working to implement a fix.
Posted Jun 04, 2025 - 16:42 EDT
This incident affected: Other.