My.usf.edu intermittent slow loading times

Incident Report for USF IT Current Systems

Resolved

The issues have been resolved and my.usf.edu is working normally.
Posted Aug 24, 2026 - 12:49 EDT

Identified

We are working with the vendor to resolve the issue.

In the meantime you can use https://www.usf.edu/myusfbackup to access my.usf.edu functionality.
Posted Aug 24, 2026 - 10:09 EDT

Investigating

We are aware that some clients using my.usf.edu are experiencing intermittent slow loading times. We are working on the issue and will provide updates here.
Posted Aug 24, 2026 - 09:32 EDT
This incident affected: MyUSF Portal.