USFCard Services Printing Issues

Incident Report for USF IT Systems Status Page

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 10:31 EDT

Investigating

We are currently unable to process/print USFCards. Updates will be provided as we work to restore services.
Posted Aug 20, 2025 - 10:06 EDT
This incident affected: Other.