The website performance issues have been resolved.
Posted May 14, 2025 - 17:07 EDT
Identified
We are aware of reports of slowness on USF public web pages. We have identified the source of the issue and are working to resolve. We will post an additional update when the issue has been fixed.
Posted May 14, 2025 - 15:51 EDT
This incident affected: BullBucks and USF Home Page.