Issues with Eduroam Connectivity

Incident Report for USF IT Systems Status Page

Resolved

These issues have been resolved. Thanks for your patience.
Posted Mar 02, 2026 - 16:26 EST

Identified

We're experiencing problems with new devices connecting to eduroam. The vendor is working promptly to resolve these issues. Devices with existing connections to eduroam should experience no impact.
Posted Mar 02, 2026 - 13:38 EST
This incident affected: Other.