Printing services have been resolved. We will continue to monitor, and thank you for your patience!
Posted Aug 26, 2025 - 10:46 EDT
Investigating
USFCard Services is experiencing intermittent issues with printing cards. If you have an urgent request or need related to printing a USFCard, please contact the IT Service Desk by email (help@usf.edu) or phone (813-974-4357).
Posted Aug 22, 2025 - 09:58 EDT
Monitoring
Printing issues for USFCards have been resolved. Technicians will continue to monitor and updates will be provided as we confirm printing functionality has been reliably restored.
Posted Aug 21, 2025 - 12:00 EDT
Investigating
We are currently unable to process/print USFCards. Updates will be provided as we work to restore services.