Power Outage on the Tampa Campus

Incident Report for USF IT Systems Status Page

Resolved

Power has been restored. We will continue to monitor for issues and will provide updates if needed.
Posted Nov 07, 2025 - 15:50 EST

Investigating

A portion of the USF Tampa campus is experiencing a power outage. This may impact some USF online resources. Support teams are responding. Updates will be posted as available.
Posted Nov 07, 2025 - 14:52 EST
This incident affected: Other.