Issues with Various USF Applications and Sites

Incident Report for USF IT Systems Status Page

Resolved

This incident has been resolved.
Posted May 28, 2026 - 22:54 EDT

Investigating

Some USF applications and websites are temporarily unavailable due to a networking issue. We are investigating and will provide updates here.
Posted May 28, 2026 - 21:37 EDT
This incident affected: Other.